股票公式:大势走向先知--三个公式搞定

炒股入门 2020-11-17 08:48炒股入门www.xyhndec.cn
股票公式:大势走向先知--三个公式搞定

大势走向如何,神人莫测。推荐三个公式,让你未卜先知。有的公式已经修改,比如“智仁参谋”,准不准,试试看。
1、背离(主图)
主线:=(ma(close,6)+ma(close,12)+ma(close,24)+ma(close,36))/4;
股价重心:=dma(amount/vol/100,vol/capital);
ma14:=ema(close,14);
ma34:=ema(close,26);
ma54:=ema(close,54);
ma90:=ema(close,90);
ma120:ema(close,120),pointdot,linethick2,colorwhite;
年线:ema(c,250),coloryellow; 
{中短波}
hz:=ema(close,13); 
短波:ema(hz,1),color00dd00,linethick1; 
中波:ema(hz,26),colorred,linethick1;
均线:=ema(c,148); 
成本:=sum(amount,0)/sum(vol,0)/100 ;
hz2:ema(hz,8),colorgreen,linethick2;
hz4:ema(hz,39),colorff00ff,linethick2;
a1:stickline(hz2<hz4,短波,hz4,1.5,0),colorblue ; 
a2:stickline(短波>hz2,短波,hz2,3,0),colorgreen; 
a3:stickline(中波>hz4,中波,hz4,2,0),colorff00ff;
{慢速kdj}
rsv:=(close-llv(low,60))/(hhv(high,60)-llv(low,60))*100;
fastk:=sma(rsv,12,1);
k:=sma(fastk,9,1);
d:=sma(k,3,1);
j:=3*k-2*d;
{中波}
var11:=3*sma((close-llv(low,75))/(hhv(high,75)-llv(low,75))*100,20,1)-2*sma(sma((close-llv(low,75)) 
/(hhv(high,75)-llv(low,75))*100,20,1),15,1); 
var22:=100-var11; 
中势线:=(-1)*(ema(var22,1)-50)+42; 
tz:=(close-llv(low,331))/(hhv(high,331)-llv(low,331))*100; 
强势线:=sma(tz,5,1); 
[url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线:=70*(hhv(high,39)-close)/(hhv(high,39)-llv(low,39));
{量选}
aa:=vol/sum(vol,13);
bb:=dma(c,aa);
cc:=vol/sum(vol,34);
dd:=dma(c,cc);
{背离}
var00:=winner(close);
var1:=forcast(var00,10); 
var2:=ma(var1,3); 
var3:=ma(var2,12); 
var4:=ma(var3,16); 
var5:=ma(var4,31); 
var6:=ma(var5,55); 
var7:=var5;
var8:=var4>var2*1.11 and var3>var2*1.095;
a:=var4/var2;
b:=var3/var2;
var9:=var2>var1*0.95; 
td:=var2/var1;
var1h:=indexc; 
var2h:=ma(var1h,6); 
var3h:=ma(var1h,24); 
var4h:=ma(var1h,32); 
var5h:=ma(var1h,62); 
var6h:=ma(var1h,105); 
var7h:=var5h; 
var8h:=var4h>var2h*1.11 and var3h>var2h*1.095; 
var9h:=var2h>var1h*0.95;
pt:=(if(h=l and c=o and l=c and c>0 and ref(h,1)=ref(l,1) and ref(c,1)=ref(o,1) 
and ref(h,1)=ref(c,1) and ref(c,1)>0,0,1))>0; 
g:=(var7h and var8h and var9h and close/cost(8)<=0.7985 
and (count(c=l,4)<3 or c>ref(c,1)))and pt or 
var7 and var8 and var9 and close/cost(5)<=0.8 and 
((var1>open or var1>ref(open,1) or 
ref(var1,1)));
背离:=var2<ref(var2,1) and a>ref(a,1);
买入:=var1>a and var2>b;
信号:=b>a and 1>b and a<1 and h=hhv(h,21);
 
drawicon(cross(短波,hz2),中波,1);
drawtext(FILTER(cross(主线,ma90) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j>k and 强势线>ref(强势线,1) and 中势线>ref(中势线,1) and 短波-ref(短波,1)>0.088 and hz4-ref(hz4,1)>0.028 or
cross(主线,ma120) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j>k and 强势线>ref(强势线,1) and 中势线>ref(中势线,1) and 短波-ref(短波,1)>0.088 and hz4-ref(hz4,1)>0.028 or 
cross(ma120,均线) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j>k and 强势线>ref(强势线,1) and 中势线>ref(中势线,1) and 短波-ref(短波,1)>0.088 and hz4-ref(hz4,1)>0.028 or
cross(中势线,33) and 短波>hz2 and o>ref(o,1) and c>ref(c,1) and j>d and j<65 and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and 强势线>36 and 主线>ref(主线,1) 
and 强势线>ref(强势线,1) and 中势线>ref(中势线,1) and 中势线<70 and c>o and ma34>ref(ma34,1) and 短波-ref(短波,1)>0.088 and hz4-ref(hz4,1)>0.028 or
cross(短波,hz2) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and 短波>中波 and 中波>hz4 and 短波-ref(短波,1)>0.088 and hz4-ref(hz4,1)>0.028 or
j>k and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and 短波>hz2 and cross(强势线,36) or cross(短波,hz2) and cross(强势线,36) or cross(j,k) and cross(强势线,33) 
or cross(短波,hz2) and cross(强势线,54)or cross(j,k) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j<65 and c>o and 短波-ref(短波,1)>0.088 or
cross(j,k) and 短波>hz2 and j<68 and 短波>ref(短波,1) and hz2>ref(hz2,1) and 中势线>ref(中势线,1) and 短波-ref(短波,1)>0.088 or
cross(j,k) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j<68 and 短波-ref(短波,1)>0.088 or cross(j,k) and cross(短波,hz2) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 or
cross(短波,hz2) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j>k and j<68 and 强势线>ref(强势线,1) and 中势线>ref(中势线,1) and 短波-ref(短波,1)>0.088 or
cross(短波,hz2) and 中波>ma120 and 中波>均线 and hz2>ma120 and ma120>均线 and 短波-ref(短波,1)>0.088 or 
cross(j,k) and 强势线>54 and 强势线>ref(强势线,1) and j<68
or count(背离,20)>1 and 短波>hz2 and o>ref(o,1) and c>ref(c,1) and j>d and j<65 and 信号=1 and 主线>ref(主线,1)
and 中势线>ref(中势线,1) and 中势线<70 and c>o or cross(bb,dd) and j<74 and ma34>ref(ma34,1) and 短波-ref(短波,1)>0.088 or
[url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j>d and j<65 and c>o and 短波>ref(短波,1) and cross(hz2,中波) and 短波-ref(短波,1)>0.088 and o>ref(c,1) or
c>o and 短波>ref(短波,1) and j>d and j<65 and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and cross(中势线,33) and 中势线-ref(中势线,1)>0.23 and 短波-ref(短波,1)>0.088 
and o>ref(c,1) and 强势线>12 or
短波>hz2 and 中波>hz4 and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and cross(j,k) and j<65 and 短波-ref(短波,1)>0.088 or
短波>hz2 and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and cross(j,k) and j<65 and 短波-ref(短波,1)>0.088 or cross(j,k) and cross(短波,hz2) and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j<56 or 
短波>hz2 and 中波>hz4 and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j>d and j<65 and cross(hz4,年线) and 短波-ref(短波,1)>0.088 or 
短波>hz2 and hz2>hz4 and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j>d and j<65 and j<65 and cross(强势线,46) and 短波-ref(短波,1)>0.088 or
短波>hz2 and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and j>d and j<65 and cross(中势线,36) and 短波-ref(短波,1)>0.088,8),hz2-0.18,'追'),colorwhite;
drawtext(cross(短波,hz2) and c>o and j>k and j>d and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and c>hz4,l*1.09,'●'),coloryellow;
drawtext(cross(短波,hz2) and c>o and j>k and j>d and [url=www.macd.cn/result.php?sn=大盘][color=blue][u]大盘[/u][/color][/url]线<36 and c>hz4,l*1.12,'做趋势'), coloryellow;
 
2、智仁参谋
jc:=sar(7,4,20);
jj:=FORCAST(EMA(jc,36),6);
FJ:=if(C>JJ,c/jc,-jc/c);
抄盘用智:SUM(FJ,0),linethick2,COLORF00FF0;
估出不仁:forcast(EMA(抄盘用智,3),18); 
 
 
 
3、多空电波
Var2:=(3*CLOSE+LOW+OPEN+HIGH)/6;
Var3:=(20*Var2+19*REF(Var2,1)+18*REF(Var2,2)+17*REF(Var2,3)+16*REF(Var2,4)+15*REF(Var2,5)+14*REF(Var2,6)+13*REF(Var2,7)+12*REF(Var2,8)+11*REF(Var2,9)+10*REF(Var2,10)+9*REF(Var2,11)+8*REF(Var2,12)+7*REF(Var2,13)+6*REF(Var2,14)+5*REF(Var2,15)+4*REF(Var2,16)+3*REF(Var2,17)+2*REF(Var2,18)+REF(Var2,20))/210;
Var4:=MA(Var3,13);
Var5:=EMA(MA(CLOSE,3),34);
Var6:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
Var7:=MA(Var6,5);
Var8:=MA(Var6,10);
〖空头市场〗: STICKLINE(IF(Var3<Var5,Var3<=1.015*Var4,Var3<=1.005*Var4),Var3,Var4,10,1),COLOR006600;
〖多头市场〗: STICKLINE(Var3>1.005*Var4,Var3,Var4,10,1),COLOR003366;
『脑电波上升』: DRAWTEXT(FILTER(MA(Var6,10)<Var7,1),Var8,'↑'),COLORRED;
『脑电波下跌』: DRAWTEXT(FILTER(MA(Var6,10)>=Var6,1),Var8,'↓'),COLORGREEN;
『多空安全线』: Var5,COLORWHITE;
〖关注点〗: STICKLINE(COUNT(Var3>1.005*Var4 AND Var3<=REF(Var3,1),2)=2 OR COUNT(IF(Var3<Var5,Var3<=1.015*Var4,Var3<=1.005*Var4) AND Var3>=REF(Var3,1),2)=2,Var3,Var4,10,0), COLORYELLOW;
★买入点: DRAWTEXT(REF(CROSS(Var3,Var4),2) AND Var3>1.005*Var4,Var4,'★买入点'),COLOR999966 ;
『多空争夺点』: DRAWTEXT(CROSS(Var6,Var7) AND Var7<Var8,Var3*0.99,'▲'),COLORBLUE;
DRAWTEXT(CROSS(Var7,Var6) AND Var7>Var8,Var3*1.01,'▼'),COLORBLUE;
Var9:=1/WINNER(CLOSE);
VarA:=MA(CLOSE,13);
VarB:=100-ABS((CLOSE-VarA)/VarA*100);
VarC:=LLV(LOW,75);
VarD:=HHV(HIGH,75);
VarE:=(VarD-VarC)/100;
VarF:=SMA((CLOSE-VarC)/VarE,20,1);
Var10:=SMA((OPEN-VarC)/VarE,20,1);
Var11:=3*VarF-2*SMA(VarF,15,1);
Var12:=3*Var10-2*SMA(Var10,15,1);
Var13:=100-Var12;
Var14:=100-Var11;
Var15:=MA(WINNER(CLOSE*0.95)*100,3);
Var16:=100-IF(Var9>5,IF(Var9<100,Var9,VarB-10),0);
Var17:=Var15>VarB;
Var18:=REF(LOW,1)*0.9;
Var19:=LOW*0.9;
Var1A:=(Var19*VOL+Var18*(CAPITAL-VOL))/CAPITAL;
Var1B:=EMA(Var1A,30);
Var1C:=CLOSE-REF(CLOSE,1);
Var1D:=MAX(Var1C,0);
Var1E:=ABS(Var1C);
Var1F:=SMA(Var1D,7,1)/SMA(Var1E,7,1)*100;
Var20:=SMA(Var1D,13,1)/SMA(Var1E,13,1)*100;
Var21:=BARSCOUNT(CLOSE);
Var22:=SMA(MAX(Var1C,0),6,1)/SMA(ABS(Var1C),6,1)*100;
Var23:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var24:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var25:=SMA((SMA(Var24,4,1)-50)*2,3,1);
Var26:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var27:=SMA(Var26,4,1);
Var28:=SMA(Var27,3,1);
Var29:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var2A:=Var22<=25 AND Var23<-95 AND Var29>20 AND Var25<-30 AND Var28<30 AND Var1B-CLOSE>=-0.25 AND Var1F<22 AND Var20<28 AND Var21>50;
DRAWTEXT(CROSS(Var2A,0.5) AND COUNT(Var2A=1,10)=1,Var4,'发射资金 ♂(超短线操作)'),COLORRED;
DRAWTEXT(CROSS(Var17,0.5) AND COUNT(Var17=1,10)=1,Var3,'激烈交锋'),COLORWHITE; 
 
(责任编辑:牛炒股网)

Copyright@2015-2020 牛炒股 炒股票,怎样炒股,新手炒股,手机炒股,炒股技巧

如何炒股,怎么炒股,炒股配资,炒股开户,如何学习炒股,炒股入门,配资炒股